ALL SCALE TREK UPDATE

Forum rules, site updates and general news.
User avatar
Xen
Bear with me
Bear with me
Posts: 1136
Joined: Sat Sep 08, 2012 1:19 am

ALL SCALE TREK UPDATE

Postby Xen » Fri Oct 28, 2016 8:55 am

AST has been experiencing intermittent tech issues (including downtime) since January 2016.

I couldn't do much until June due to ongoing health problems. I was also unaware of the source, the extent of the problems and needed to talk to a few people (the host, phpbb software dev's, php dev's) to work out what might be happening.

A few things have been tried, including seemingly doubling the allocated resources around July. All resources stabilized to nominal levels with the exception of CPU usage. I don't understand how it can be hitting the limit even more now when the host doubled the allocated amount. Traffic stats have steadily increased each month since we launched. No boom. No reason for these spikes. Someone suggested Bots as the culprit and that there was no way to fix that. Cloudflare was suggested. That has yet to be tested. The host response to that suggestion was "try it out and we'll discuss options if it doesn't work".

From what I can see the average CPU usage is 80% most of the time (which seems high) and then jumps up to the limit at least once a day. All resources are then capped. I have asked several times what happens when it gets capped as I had no idea what they do, and if anything, for how long. Those questions remain unanswered.

I didn't know that in capping the resources meant no site and an error message. I appreciate the folks who have taken the time to report their findings to me. Most do not and simply leave. I understand, but would still like to win them back. It saddens me at the thought of people turning away because of downtime (not that I can blame them).

If you do know of folks that have left, please help spread the word that we are trying to fix this. I want it fixed NOW, working well for everyone. ALL posts have been noted, with the intention of fixing this.

The host has provided a good, hassle-free service for AST up until 2016. Then, for whatever reason, the !!!!!!!! hit the fan. I do not understand why a niche fan forum (albeit it a very active one, relatively speaking) has these CPU usage issues.

Can someone explain that to me? Are there special requirements now that I am unaware of in order to keep a forum smooth for visitors?

If you know your stuff when it comes to php, phpbb, hosting etc, and can provide me with insight and solutions, then feel free to post here. I do have a dev I was working with that should still be available, but at this point, the more input the better.

I am aware of one member who PM'd me. My apologies for not replying. You joined the "need to reply" list, dating back to March.

User avatar
Del
Starship Engineer
Starship Engineer
Posts: 1979
Joined: Mon Oct 08, 2012 7:37 pm
Location: Lawton, Oklahoma
Contact:

Re: ALL SCALE TREK UPDATE

Postby Del » Fri Oct 28, 2016 1:51 pm

Well, there is a lot of hacking going on around the world now, and DoS attacks using the resources of innocent servers and systems to aid with the disruptions. Perhaps your hosting service has been unknowingly used and this might be part of the problem, or your hosting service might have been directly targeted and maybe everyone using them experienced the same issues.

I was able to access AST very easily just now, so I think it might be an intermittent problem, not systemic. Could be upgrades or server maintenance conducted during these times as well. I've mentioned before that sometimes my website is down and I find it troubling, but within an hour or two it comes back online with no issues.
Multi-Verse Models - http://www.mvmodels.biz or find me on Facebook
Producing kits previously sold thru Ravenstar, Novahobbies, Fantastic Plastic, NorthTrek Creations, and more!

User avatar
MEATLOAFr
Rampaging Rear Admiral (LH)
Rampaging Rear Admiral (LH)
Posts: 1634
Joined: Fri Sep 28, 2012 12:46 pm
Location: Lincoln, Nebraska

Re: ALL SCALE TREK UPDATE

Postby MEATLOAFr » Fri Oct 28, 2016 10:10 pm

Del wrote:Well, there is a lot of hacking going on around the world now, and DoS attacks using the resources of innocent servers and systems to aid with the disruptions. Perhaps your hosting service has been unknowingly used and this might be part of the problem, or your hosting service might have been directly targeted and maybe everyone using them experienced the same issues.

I was able to access AST very easily just now, so I think it might be an intermittent problem, not systemic. Could be upgrades or server maintenance conducted during these times as well. I've mentioned before that sometimes my website is down and I find it troubling, but within an hour or two it comes back online with no issues.


I agree, the DoS attacks lately might be of some of the problems, along with the bots

I haven't seen anything wrong when I've been logged in lately, but will keep an eye out
If the world ends tomorrow, it's ALL YOUR FAULT!!!

User avatar
Xen
Bear with me
Bear with me
Posts: 1136
Joined: Sat Sep 08, 2012 1:19 am

Re: ALL SCALE TREK UPDATE

Postby Xen » Sun Oct 30, 2016 1:58 pm

Folks like Tesral are oldschool and loyal enough to let us know about 1-2 day site downtime. He's in the US. Kobayashi has had similar problems. He's in Australia. I think Julien has reported frequent slow load times. He's in Belgium.

So, that's all over, at different times, yet all with similar problems. Slow load times, blank pages navigating the site, error pages. Before the upgrade and continuing afterwards.

The PHPMyAdmin section locks up on me (and for the dev). A possible clue pointing to a database problem?

I'm going to find out about that first, from various sources hopefully. See if there's a solution (the host says it works fine for them).

Cloudflare is an option after that. However, I have been led to believe this is down to the host.

I will do my best to fix this.

User avatar
Tesral
Resolute Rear Admiral (UH)
Resolute Rear Admiral (UH)
Posts: 2433
Joined: Tue Dec 18, 2012 12:58 pm
Location: Dearborn, Mi -- at my desk.
Contact:

Re: ALL SCALE TREK UPDATE

Postby Tesral » Sun Oct 30, 2016 3:46 pm

Thank you. Yes I have had latency problems and the 508 error. Usually waiting a moment and reloading solves it. Both come and go and over the last several days have not been and issue.

If it is a host issue getting them to admit it is like pulling teeth...on a chicken.
Garry AKA --Phoenix-- Rising above the Flames.
"I saw it done on Voyager" is no excuse for anything, even breathing.

User avatar
TrekMD
Can-Do Captain
Can-Do Captain
Posts: 617
Joined: Mon Nov 19, 2012 9:57 pm
Location: Coral Gables, FL
Contact:

Re: ALL SCALE TREK UPDATE

Postby TrekMD » Mon Oct 31, 2016 3:04 am

I must be lucky as I've not experienced any issues with this forum. I'm not going to complain but good that the issues are being addressed. Let's hope whatever is causing the issue can be fixed.
Medicus ad astra, non laedant...
Image

User avatar
andyh
Can-Do Captain
Can-Do Captain
Posts: 662
Joined: Tue Apr 22, 2014 11:08 pm
Location: Adelaide, South Australia

Re: ALL SCALE TREK UPDATE

Postby andyh » Mon Oct 31, 2016 7:10 am

I got a 508 error on my phone the other day whilst trying to access the site, but didn't really think anything of it. I went onto the computer and accessed the site just after that so I assumed it was just an issue with the browser on my iphone.

Andy


Return to “Important”

Who is online

Users browsing this forum: No registered users and 5 guests