Enterprise E 2.0 (PIC HEAVY)

WiP, finished models and general 1/1400 chit chat.
SKO
Legendary LT Commander
Legendary LT Commander
Posts: 132
Joined: Wed May 07, 2014 1:38 am

Enterprise E 2.0 (PIC HEAVY)

Postby SKO » Sun Jul 16, 2017 5:01 am

So this was my old Enterprise E. It doesn't look terrible in these pictures but it was very flawed. First built when I was 19 and I sprayed all of the parts w krylon while they were on their trees. I was not aware at the time that the glue would just melt the paint. I ended up with a globby mess and tons of seams and gaps. I broke the nacelle pylons. Years later I fixed a lot of the damage and ordered a set of Acreation Aztecs. I was pleased with her but since then my skills have evolved and she bugged me again. Gaps remained. My thrusters were poor blobs. I never did the windows. I knew nothing of gloss coating before decals or setting solutions so bubbles and silvering dominated. My resin replacement nacelles were warped and angled outward and I never knew how to fix em without snapping them off. Eventually I tried doing the windows w the horrible result pictured below
Image
Image
Image
20160807_142654.jpg

Image

The story has a happy ending though as I finally had the chance to just do the entire thing over from the ground up. I'm far happier with the results this time:
Image
Image
Image
Image
20170714_174417-1161x2064.jpg

User avatar
scaddude
Lighting Fast Lieutenant JG
Lighting Fast Lieutenant JG
Posts: 40
Joined: Thu Dec 15, 2016 5:35 pm

Re: Enterprise E 2.0 (PIC HEAVY)

Postby scaddude » Tue Jul 18, 2017 9:45 pm

Nicely done!
"If nothing we do matters, all that matters is what we do..."


Return to “1/1400”

Who is online

Users browsing this forum: No registered users and 26 guests